horn beeping after rain - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-26-2010, 07:46 PM Thread Starter
Wheeler
 
jsebastian's Avatar
 
Join Date: Jun 2010
Location: Queens, NY
Age: 36
Posts: 85
Feedback: 0 reviews
Send a message via AIM to jsebastian
horn beeping after rain

So I got caught in the rain yesterday doorless and with only a safari top. Everything was pretty wet. A few hours later, the horn would just beep for a good 5 seconds every 10 minutes or so. It happened a few times before I finally decided to pull out the fuses until everything dried out. Reinstalled the fuses today and haven't had any more issues. Has this ever happened to anyone?

John


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jsebastian is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-26-2010, 08:01 PM
JKO Addict!
 
tkob1060's Avatar
 
Join Date: Jun 2009
Location: NJ :)
Age: 51
Posts: 7,281
Garage
Feedback: 0 reviews

steering wheel get wet? the clock spring inside it does NOT like to get wet


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Quote:
Originally Posted by Dancin Dan View Post
A Jeep just zipped past my house and I could swear I heard the driver yellin:

"The tkob is coming!! The tkob is coming!!"
tkob1060 is offline  
post #3 of 4 Old 07-26-2010, 08:13 PM Thread Starter
Wheeler
 
jsebastian's Avatar
 
Join Date: Jun 2010
Location: Queens, NY
Age: 36
Posts: 85
Feedback: 0 reviews
Send a message via AIM to jsebastian

Speaking from experience? Yeah, the steering wheel was wet. I figured something was shorting out. But it didn't start happening until hours after it got wet. Maybe it took a while for the water to get to the clock spring?

John


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jsebastian is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 08-01-2010, 10:38 AM
Wheeler
 
bkoliba's Avatar
 
Join Date: Sep 2009
Age: 52
Posts: 14
Feedback: 0 reviews

Yep, the exact same thing happened to me a while back.
bkoliba is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome