Loosing power to Datalink connector - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-07-2016, 04:44 AM Thread Starter
Rock God
 
Join Date: Apr 2009
Posts: 519
Feedback: 0 reviews
Loosing power to Datalink connector

Need some help....

I am loosing power to Datalink connector and PCM dies because it has no power. My Fuse M3 keeps blowing there is short circut some where.

Just checked the wires they seem ok. If i supply 12 v power to pin 16 at datalink connector it fires up the engine ok

Trying to find out what circuts this M3 fuse holds so i can check everything...
JK07 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-07-2016, 05:23 AM
Rock God
 
ronjenx's Avatar
 
Join Date: Aug 2010
Location: Maine
Posts: 1,874
Feedback: 0 reviews

What year is your JK?

According to the 2008 wiring diagram, M3 feeds only the data link connector and the powertrain control module.

2008 Unlimited Rubicon Automatic
ronjenx is offline  
post #3 of 3 Old 01-07-2016, 06:24 AM Thread Starter
Rock God
 
Join Date: Apr 2009
Posts: 519
Feedback: 0 reviews

Its a 2007 model sahara with manual tran. I just recently replaced the TIPM thru dealer.

Correction.

Sorry its M28 fuse which keeps blowing and shutting down PCM.
According to manual M28
Red

Next Generation Controller (NGC), Transmission Feed (TRANS FEED), J1962
JK07 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome