09 JK X - Interior Lights not Working - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-22-2015, 09:39 PM Thread Starter
Newbie
 
Join Date: Sep 2015
Posts: 3
Feedback: 0 reviews
09 JK X - Interior Lights not Working

Hi all,

New to the jeep world as of March and having fun - Hoping to get some help with a lighting issue.

The lights on the center panel are not working (HVAC, buttons).
The lights on the Gear Shifter are not working.
The lights on the instrument panel do come on jut fine and are dimmable via the stick.

A few weeks back while driving the center panel and gear shifter flickered a bit and finally just won't come on anymore.

Checked all fuses and they are not blown.

Thoughts??

Thanks in advance!
tuc8458 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-28-2015, 11:44 PM
Wheeler
 
Join Date: Jul 2015
Posts: 30
Feedback: 0 reviews

Were there any funny smells when the dash started having its issues?
thzpcs is offline  
post #3 of 6 Old 09-30-2015, 09:39 AM Thread Starter
Newbie
 
Join Date: Sep 2015
Posts: 3
Feedback: 0 reviews

Good morning -

No smells whatsoever - The items functioned at one time until the lights flickered and than finally went out.

Thanks - Steve
tuc8458 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 12-29-2015, 01:00 AM
Newbie
 
Join Date: Dec 2015
Posts: 1
Feedback: 0 reviews

Hi Steve,

Did you ever get a fix to this, my 08 has done the same thing done lights and hav packed in at the same time, fuses ok

Cheers,

Paul
Paulw106 is offline  
post #5 of 6 Old 03-01-2016, 09:12 PM Thread Starter
Newbie
 
Join Date: Sep 2015
Posts: 3
Feedback: 0 reviews
Interior Lights not working - SOLVED

Finally got some time to really dig into this...

It turns out the fuse was not blown but was 'flimsy'. If I pushed on it just the right way lights work fine. Replaced the fuse with a new one and all is well.

I did test the 'flimsy' fuse in other slots that take 15AMP fuses and those items would not work with that fuse. So it is the fuse and not the TIPM that the dealer diagnosed as the issue and wanted to charge $1k to replace.
tuc8458 is offline  
post #6 of 6 Old 03-02-2016, 09:27 AM
Wheeler
 
Join Date: Apr 2013
Posts: 17
Feedback: 0 reviews

That's crazy that the fuse did that. Those freaking dealerships are a useless a tits on a boar. I've asked them some tech questions and if it is not at there fingertips then they do not have clue.
Topekafire is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome