Sirius Reception Problem - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 15 Old 04-28-2010, 07:37 PM Thread Starter
Newbie
 
Join Date: Dec 2009
Age: 66
Posts: 6
Feedback: 0 reviews
Sirius Reception Problem

Is anyone having recent problems with Factory Sirius reception>
Mine started a few days ago.

It's almost like the antenna wiring may be loose but it also has symptoms of a low transmit signal from the Sirius satellite.

Thanks
belmoresr is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 04-28-2010, 07:39 PM
Wheeler
 
Join Date: Jan 2010
Location: Columbus, OH
Posts: 39
Feedback: 0 reviews

Yes, I've got a 2010 Rubi Unlimited that's about three months old and my Sirius reception just starting going in/out too. Not sure what's up.
Bujkeye is offline  
post #3 of 15 Old 04-28-2010, 08:12 PM
Rock God
 
MaloCS's Avatar
 
Join Date: Apr 2009
Location: Denver, CO
Age: 48
Posts: 578
Feedback: 0 reviews

Bad antennas. More then likely they're going bad or there's some sort of interference with rook racks, sport cages, etc...

The OEM head unit uses a standard connector so you could always buy a cheap replacement from Car Toys, Best Buy, etc... and verify the antenna problem. If you go this route you can mount the antenna on the hood cowl for better reception.





And here's a very good antenna from Car Toys made by Terk. Take special note of the connector. This antenna plugs right into the head unit; no splicing or adapters needed.


Those that the beast is looking for...
Listen in awe and you will hear him...
BARK AT THE MOON!

Last edited by MaloCS; 04-28-2010 at 08:15 PM.
MaloCS is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old 04-28-2010, 08:19 PM
Rock God
 
Guruman's Avatar
 
Join Date: Feb 2010
Location: Thompson Falls, Montana
Age: 48
Posts: 1,184
Garage
Feedback: 0 reviews

I had similar issues about a year ago. It turns out the antenna cable for the sat was getting pinched behind or on top of the radio unit. I was able to just reposition the wiring, and I have not had the problem since.

It's worth a shot.

_
'76 CJ-7, '43 CJ-2a, '78 Bronco,'78 CJ-7, '75 CJ-5, '78 CJ-7, '80 CJ-7, '78 SJ, '79 SJ, '78 and a '76 FJ-40 , '90 XJ, '91 XJ, '86 CJ-7, '95 ZJ, '68 CJ-101 Commando, '00 TJ, '68 M-715, 2 '86 Military Blazers, '96 LR Discovery, '86 CJ-7, '91 YJ, '99 TJ, 07' JKU Rubi, 1988 YJ, 1973 Commando, 3 Diesel Excursions....
Now back to a 2013 JKU Rubicon with "stuff", planning 37's with minimal lift.

I've tried them all... Jeeps are still the best. (0||||0)
Guruman is offline  
post #5 of 15 Old 04-28-2010, 10:21 PM
Wheeler
 
Join Date: Apr 2010
Posts: 13
Feedback: 0 reviews

I have problems in the winter when I have my ski hauler on my jk. If I load the roof up with skis, I get no reception whatsoever. I'm assuming the metal in the skis block the reception. I'd think if you installed a metal rack on the roof or something like that, you'd have a similar problem. Good luck.
Rotmilky is offline  
post #6 of 15 Old 05-02-2010, 10:27 AM
Rock God
 
H3ATH3N's Avatar
 
Join Date: Aug 2009
Location: Jacksonville, FL
Posts: 1,054
Feedback: 0 reviews

Quote:
Originally Posted by MaloCS View Post
And here's a very good antenna from Car Toys made by Terk. Take special note of the connector. This antenna plugs right into the head unit; no splicing or adapters needed.
Do you have a link to this antenna? Does that plug type have a formal name?

I have searched for that specific antenna, and I have come up empty handed.

Life moves pretty fast. You don't stop and look around once in a while, you could miss it.
H3ATH3N is offline  
post #7 of 15 Old 05-03-2010, 09:44 AM
Rock God
 
MaloCS's Avatar
 
Join Date: Apr 2009
Location: Denver, CO
Age: 48
Posts: 578
Feedback: 0 reviews

Quote:
Originally Posted by H3ATH3N View Post
Do you have a link to this antenna? Does that plug type have a formal name?

I have searched for that specific antenna, and I have come up empty handed.
Sorry but I don't have a direct link. This specific antenna is made by Terk and can be picked up at Car Toys; at least that's where I got mine. It retailed for about $30 and they had it in stock. I've been told that Best Buy and Ultimate Electronics also carry them in stock.

The key, no matter the brand, is the connector that's shown in the photo. Any Sirius antenna should work as long as it has that specific connector. I would print the photo and take it with you for a comparison before buying.

Good luck.

Those that the beast is looking for...
Listen in awe and you will hear him...
BARK AT THE MOON!
MaloCS is offline  
post #8 of 15 Old 05-03-2010, 03:05 PM
Granite Guru
 
Join Date: Apr 2008
Location: W of Ft Worth
Posts: 236
Feedback: 1 reviews

Mine quit receiving last week, had a number to call to "subscribe"... I called it to see WTF.. the lady said "oh we have to reactivate your radio every so often".. didn't take very long, but all presets are gone.

The Exim in my wife's Lexus goes dead around the square in our little town.. I blame it on the city's wifi antennas? The Jeep doesn't do it as bad..
cowboy49 is offline  
post #9 of 15 Old 05-03-2010, 04:33 PM
Rock God
 
Tail Rated's Avatar
 
Join Date: Feb 2009
Location: Aurora CO
Posts: 1,289
Feedback: 0 reviews

...just did the same mod!! After the GOBI rack, I had some reception issues, so new Car Toys antenna and all is good. Drove around in circles.
no more issues. ...although I did get a little dizzy!

2016 JKU
Tail Rated is offline  
post #10 of 15 Old 05-03-2010, 04:43 PM
Rock God
 
v10kingsnake's Avatar
 
Join Date: Feb 2009
Posts: 1,466
Feedback: 1 reviews

not sure about you guys but near me a lot of roads are surrounded by trees. in the winter, it is not an issue but as spring hits and leaves are full in the trees, the shade cover blocks the sat signal causing intermittent interruption.

2009 Sahara Unlimited. 5.7L Hemi truck setup. Rock Krawler 5.5 coil over LA. Maxxis Trepador 40's . ATX Rims, XRC front rear and side armor. RROR Crusher corners, RROR flat flares. Warn XD9000i. Prorock 44 with RCV shafts. 5.13 gears, ARB front and rear lockers.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
v10kingsnake is offline  
post #11 of 15 Old 05-03-2010, 06:49 PM
Granite Guru
 
Dragline's Avatar
 
Join Date: Dec 2007
Location: Richmond, VA
Posts: 271
Feedback: 0 reviews

Quote:
Originally Posted by v10kingsnake View Post
not sure about you guys but near me a lot of roads are surrounded by trees. in the winter, it is not an issue but as spring hits and leaves are full in the trees, the shade cover blocks the sat signal causing intermittent interruption.
x2 - drives me crazy!

08 Rubicon 2DR Red Rock

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dragline is offline  
post #12 of 15 Old 05-03-2010, 07:10 PM
Rock God
 
H3ATH3N's Avatar
 
Join Date: Aug 2009
Location: Jacksonville, FL
Posts: 1,054
Feedback: 0 reviews

Looks like the plug type is knows as a FAKRA plug. I could not locate that TERK antenna on the car toys site, but their are plenty results on Google.

Here is a link to the TERK antenna MaloCS is referring to, but it's out of stock.

Here is an adapter I located if you don't want to be limited to a particular antenna.

I am looking at going with something like this. 35dB of gain should resolve any reception issues.

Life moves pretty fast. You don't stop and look around once in a while, you could miss it.
H3ATH3N is offline  
post #13 of 15 Old 05-06-2010, 07:36 PM Thread Starter
Newbie
 
Join Date: Dec 2009
Age: 66
Posts: 6
Feedback: 0 reviews
Problem resolved itself

I did nothing and the situation cleared itself up.

I suspect that Sirius had transmitting problems.

thanks for all the help.

Last edited by belmoresr; 05-06-2010 at 10:51 PM.
belmoresr is offline  
post #14 of 15 Old 05-08-2010, 02:47 PM
Wheeler
 
Join Date: Mar 2009
Location: western mass-hole
Age: 36
Posts: 77
Feedback: 0 reviews

I had really patchy reception with my stock radio, 100x better soon as I upgraded to my kenwood using the stock antenna .

07' Rubicon Unlimted.
pha-cue is offline  
post #15 of 15 Old 05-08-2010, 03:06 PM
Rock God
 
Jagrmaister's Avatar
 
Join Date: Dec 2009
Location: Chicagoland
Posts: 670
Feedback: 0 reviews

I've had mine since last september, and other than occassionally going out under a bridge, and a couple sporadic lost signals a couple days ago during some heavy storms rolling in, there hasn't been any problems with it.

2010 Jeep Wrangler 2dr Rubicon with a part from everyone...
Jagrmaister is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome