AMP HELP - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 04-15-2010, 12:36 AM Thread Starter
Rock God
 
2008jkx's Avatar
 
Join Date: Jan 2009
Age: 28
Posts: 603
Feedback: 0 reviews
AMP HELP

HEY! so after 2 hour of setting up my subs and amp i get it all turned on and only the red protection light comes on..

why is this! its a ppi2240 with 2 8 in JB audio subs

2013 rubi axles. 2.5in RK max travel. coast front DS.. rockhard oil pan and tranny skid plate. xrc 8 comp winch mounted on RR XHD

south lake tahoe california.
2008jkx is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-15-2010, 01:52 AM
Wheeler
 
Webhead's Avatar
 
Join Date: Jan 2010
Location: Northeast Illinois
Posts: 80
Garage
Feedback: 0 reviews

If you remove the input wires and the wires to the subs, does the protection light still come on?

Is the amp grounded to bare metal?

2010 2-door, Dark Charcoal, 6-speed Rubi
Webhead is offline  
post #3 of 5 Old 04-15-2010, 05:14 AM
JKO Addict!
 
usmcdoc14's Avatar
 
Join Date: Oct 2007
Location: Norfawk, va
Posts: 3,881
Feedback: 1 reviews

ground, did your remote wire touch the ground, is a strand of it touching ground, fuse on AMP blown, disconnect speakers and try again, pull fuse and wait then try again.
usmcdoc14 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 04-15-2010, 07:14 AM
JKO Addict!
 
BeerMonkeY's Avatar
 
Join Date: Sep 2007
Location: Lake Winola, PA
Age: 42
Posts: 6,283
Garage
Feedback: 0 reviews

do like they said, if you un hook everything but the power wires and it still does it the amp is prob bad, if you unhook that stuff and it doesnt do it then hook the rca's back up and try it again. if it does it then the rca are prob bad if it doesnt do it then the speaker wires are shorted or the subs are bad

'92 YJ
'13 WK2
BeerMonkeY is offline  
post #5 of 5 Old 04-15-2010, 09:10 PM Thread Starter
Rock God
 
2008jkx's Avatar
 
Join Date: Jan 2009
Age: 28
Posts: 603
Feedback: 0 reviews

of course it was just the ground... a 240 watt bridged with 2 jl audio 8s sounds pretty good

2013 rubi axles. 2.5in RK max travel. coast front DS.. rockhard oil pan and tranny skid plate. xrc 8 comp winch mounted on RR XHD

south lake tahoe california.
2008jkx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome