CB ISSUES - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 08-08-2014, 07:49 AM Thread Starter
Granite Guru
 
bass5money's Avatar
 
Join Date: May 2014
Age: 48
Posts: 373
Feedback: 0 reviews
CB ISSUES

SO I bought and installed a cobra 75 cb with firestick antenna and quick disconnect. even with squelch all the way down a get a choo choo choo choo noise. Took it to TTT truck stock cb guy and he says the install is just like he would have done and looks good. He tested the receiver and cb and they are fine. he said possibly something else grounded could be causing it.
I removed everything electronic that I anstalled from battery and still does it. Removed the 2 sets of grounded wire harnesses from inside passenger wall and still does it. no key in care nothing turned on it still does it.
I remove the entenna and it gets very quiet re-install it and it get loud again.
I am stumped and cb guy is stumped, he said if I figure it out call him and tell him what it was..

Has anyone had a similar issue? Oh and he also said the more ground added makes it worse..

2014 jk oscar mike edition. Manual. 3.5" Rubicon super flex suspension lift. 35" AT tires 17" method rims. Body armor doors. Smitty built MOD front bumper. Smittybilt 9500 lb winch, ARB twin compressor, Spod with gauge, D2 LED's.
bass5money is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 08-08-2014, 09:58 AM
Rock God
 
2Door's Avatar
 
Join Date: Oct 2013
Location: New Brunswick, Canada
Posts: 979
Garage
Feedback: 0 reviews

Try removing that disconnect.

The problem lies in your coax cable, back to the antenna. Start at the radio box and work back. If you determine the cable to be good, which it probably is because you mentioned that you removed the antenna and it was better, antenna mount and grounding. Also, check how you installed the Firestik antenna onto the stud (they have a certain order for washers and stuff) cause it might be grounding out.

Finally, did you tune it? Mine is tuned to 1.5 (I have the same setup) and it has been working really well.

2011 Sahara Tan 2dr Rubicon
Rock Krawler Stock Mod w/ Fox Evolution 2.0's - 36 X 12.5 X 15" Interco TSL's on Black Steel wheels - Rock Krawler track bars front and back - Poison Spyder Customs BFH front bumper w/ Brawler bar - Warn HS9500i winch w/ synthetic rope - Trail Head Deflators - Viair 440P Compressor Instagram: jeepethan
2Door is offline  
post #3 of 18 Old 08-08-2014, 10:12 AM
Rock God
 
funfred's Avatar
 
Join Date: Nov 2013
Location: Bloomsburg, PA
Posts: 1,138
Feedback: 0 reviews

Are you near any kind of radar array like an airport or doppler weather station?
funfred is offline  
Sponsored Links
Advertisement
 
post #4 of 18 Old 08-09-2014, 10:27 PM Thread Starter
Granite Guru
 
bass5money's Avatar
 
Join Date: May 2014
Age: 48
Posts: 373
Feedback: 0 reviews

Ran new cable same issue. Checked ground with meter from antenna ground to chassis that's good. Truck stop tested cb that's good. Tried another antenna still does it. Tried running new power and ground from transmitter outside jeep to battery same thing. Tried putting a fuse on ground line again same thing.
Nothing is turned on no key in jeep nothing on still does it. I grab top of antenna noise stops. Pull ground from battery went to chassis still problem. Pulled ground again not connected to anything and the cb still has power..weird..
Maybe just a bad transmitter? Tried to buy another today went to 5 places nobody has one. Tried getting ahold of righchannel.com were I got it at..they have no phone number..emailed them no reply yet.
I am so frustrated.

2014 jk oscar mike edition. Manual. 3.5" Rubicon super flex suspension lift. 35" AT tires 17" method rims. Body armor doors. Smitty built MOD front bumper. Smittybilt 9500 lb winch, ARB twin compressor, Spod with gauge, D2 LED's.
bass5money is offline  
post #5 of 18 Old 08-09-2014, 10:29 PM Thread Starter
Granite Guru
 
bass5money's Avatar
 
Join Date: May 2014
Age: 48
Posts: 373
Feedback: 0 reviews

Not near any airport it does it anywhere.

2014 jk oscar mike edition. Manual. 3.5" Rubicon super flex suspension lift. 35" AT tires 17" method rims. Body armor doors. Smitty built MOD front bumper. Smittybilt 9500 lb winch, ARB twin compressor, Spod with gauge, D2 LED's.
bass5money is offline  
post #6 of 18 Old 08-09-2014, 10:46 PM
Probably Stuck on my Diff
 
11jeeperdrummer's Avatar
 
Join Date: Oct 2011
Location: Tucson
Age: 32
Posts: 1,276
Feedback: 0 reviews

Hey man, careful with TTT, those guys really arent helpful. I went there when everytime I keyed up, my windshield wipers would go on.. He was telling my how my radio must be pushing more power than normal.. turns out it was a bad antenna mount ground. I would suggest you get a multimeter and check the continuity between the cable and the antenna mount and the firestik adapter.

If you grab the top the of antenna and it stops, that sounds to me like a bad ground. (either the antenna or the mount).

More Cowbell

Last edited by 11jeeperdrummer; 08-09-2014 at 10:48 PM.
11jeeperdrummer is offline  
post #7 of 18 Old 08-10-2014, 10:50 PM
Rock God
 
UnlimiDozer's Avatar
 
Join Date: Mar 2012
Location: Tulare, CA
Posts: 1,495
Garage
Feedback: 0 reviews

Quote:
Originally Posted by 2Door View Post
. . . check how you installed the Firestik antenna onto the stud (they have a certain order for washers and stuff) cause it might be grounding out.
Quote:
Originally Posted by 11jeeperdrummer View Post
If you grab the top the of antenna and it stops, that sounds to me like a bad ground. (either the antenna or the mount).
Go to this link and compare to your installation. It could be that you have the fire ring upside down. If so, you would be trying to use your Jeep as an antenna and your antenna as a ground plane. No so bueno.

http://www.firestik.com/Tech_Docs/mkfr-instl_nohook.htm

My Build Thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


I'm the NRA
JOIN HERE:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UnlimiDozer is offline  
post #8 of 18 Old 08-10-2014, 10:55 PM
Rock God
 
2Door's Avatar
 
Join Date: Oct 2013
Location: New Brunswick, Canada
Posts: 979
Garage
Feedback: 0 reviews

Before I bought mine, I heard of guys having issues with the grounding of the fire ring cables. So, I opted out and just bought a regular coax. If it is stopping when you grab the top, could it be a tuning issue?

2011 Sahara Tan 2dr Rubicon
Rock Krawler Stock Mod w/ Fox Evolution 2.0's - 36 X 12.5 X 15" Interco TSL's on Black Steel wheels - Rock Krawler track bars front and back - Poison Spyder Customs BFH front bumper w/ Brawler bar - Warn HS9500i winch w/ synthetic rope - Trail Head Deflators - Viair 440P Compressor Instagram: jeepethan
2Door is offline  
post #9 of 18 Old 08-11-2014, 04:30 AM
Rock God
 
bgall's Avatar
 
Join Date: Feb 2012
Posts: 1,272
Feedback: 0 reviews

Definitely sounds like antenna grounding. No pics makes it hard for us to help. Are you using just the mount for ground or did you run an extra ground? How did you test ground to chassis? I always run an extra split ring ground from the antenna to the body. Just make sure you do NOT touch the antenna core when you run one. There should be zero continuity between the lower mount and antenna on top.

I have jeeps. I do shit to them.
bgall is offline  
post #10 of 18 Old 08-11-2014, 06:32 AM Thread Starter
Granite Guru
 
bass5money's Avatar
 
Join Date: May 2014
Age: 48
Posts: 373
Feedback: 0 reviews

I don't have a fire rind set up. I have a fire stick antenna and coax cable. The lipped part of the washer is facing down.

2014 jk oscar mike edition. Manual. 3.5" Rubicon super flex suspension lift. 35" AT tires 17" method rims. Body armor doors. Smitty built MOD front bumper. Smittybilt 9500 lb winch, ARB twin compressor, Spod with gauge, D2 LED's.
bass5money is offline  
post #11 of 18 Old 08-11-2014, 06:41 AM Thread Starter
Granite Guru
 
bass5money's Avatar
 
Join Date: May 2014
Age: 48
Posts: 373
Feedback: 0 reviews

I'll try to make a vid..

2014 jk oscar mike edition. Manual. 3.5" Rubicon super flex suspension lift. 35" AT tires 17" method rims. Body armor doors. Smitty built MOD front bumper. Smittybilt 9500 lb winch, ARB twin compressor, Spod with gauge, D2 LED's.
bass5money is offline  
post #12 of 18 Old 08-11-2014, 08:28 PM
Rock God
 
UnlimiDozer's Avatar
 
Join Date: Mar 2012
Location: Tulare, CA
Posts: 1,495
Garage
Feedback: 0 reviews

Quote:
Originally Posted by bass5money View Post
I don't have a fire rind set up. I have a fire stick antenna and coax cable. The lipped part of the washer is facing down.
My mistake. Guess I just assumed . . .

My Build Thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


I'm the NRA
JOIN HERE:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UnlimiDozer is offline  
post #13 of 18 Old 08-12-2014, 12:10 AM
Rock God
 
BumpInTheRoad's Avatar
 
Join Date: Apr 2010
Posts: 1,694
Garage
Feedback: 7 reviews

Quote:
Originally Posted by bass5money View Post
I don't have a fire rind set up. I have a fire stick antenna and coax cable. The lipped part of the washer is facing down.
Not sure if I'm envisioning this right, but the mounting sequence should be, from top-to-bottom:

Antenna
Antenna Base
Lock Washer
Flat Washer
Nylon Insulating washer
Mount
Coax Connector


I'm a JKO Reject
BumpInTheRoad is offline  
post #14 of 18 Old 08-12-2014, 06:24 AM Thread Starter
Granite Guru
 
bass5money's Avatar
 
Join Date: May 2014
Age: 48
Posts: 373
Feedback: 0 reviews

Yes it's just like that ^^^^^^ minus the lock washer and split ring . Plastic washer with flanged side down.

2014 jk oscar mike edition. Manual. 3.5" Rubicon super flex suspension lift. 35" AT tires 17" method rims. Body armor doors. Smitty built MOD front bumper. Smittybilt 9500 lb winch, ARB twin compressor, Spod with gauge, D2 LED's.
bass5money is offline  
post #15 of 18 Old 08-12-2014, 09:23 AM
Rock God
 
bgall's Avatar
 
Join Date: Feb 2012
Posts: 1,272
Feedback: 0 reviews

and split ring ground will attach between the coax connector and mounting bracket without touching the inner core of the threaded adapter.

I have jeeps. I do shit to them.
bgall is offline  
post #16 of 18 Old 08-12-2014, 09:25 AM
Probably Stuck on my Diff
 
11jeeperdrummer's Avatar
 
Join Date: Oct 2011
Location: Tucson
Age: 32
Posts: 1,276
Feedback: 0 reviews

Did you make sure to grind down the inside of the hole and the bottom of the mount where the firestik adapter mounts to? Those need to be clean metal.

More Cowbell
11jeeperdrummer is offline  
post #17 of 18 Old 08-13-2014, 01:42 PM Thread Starter
Granite Guru
 
bass5money's Avatar
 
Join Date: May 2014
Age: 48
Posts: 373
Feedback: 0 reviews

yes.. I finally got a reply from rightchannel. they are sending me another system, he even agreed i was doing everything right.. I'll post up what happens when get the new one..

2014 jk oscar mike edition. Manual. 3.5" Rubicon super flex suspension lift. 35" AT tires 17" method rims. Body armor doors. Smitty built MOD front bumper. Smittybilt 9500 lb winch, ARB twin compressor, Spod with gauge, D2 LED's.
bass5money is offline  
post #18 of 18 Old 08-19-2014, 06:14 PM
Wheeler
 
Join Date: May 2012
Location: Indiana
Posts: 30
Feedback: 0 reviews

Where do you have antenna mounted to? Sounds lik possible bad radio. Ive seen a lot of bad grounds that mad no noise just coult transmit or receive
bhiland is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome