07 Rubicon Engine will not shut off! - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-10-2014, 10:00 PM Thread Starter
Wheeler
 
SJJKUR's Avatar
 
Join Date: Jun 2012
Location: West Deptford
Age: 29
Posts: 10
Feedback: 0 reviews
07 Rubicon Engine will not shut off!

So I went wheeling earlier and took some water in. Enough that it was up close to the bottom of the seat cushion but not as high as the shifter.

15 minutes later, turned off the jeep and turned it back on like normal. An hour later I stopped to get food on the way home. I turn it off and get out of the Jeep and notice it's making a weird sound. Then I realized that the engine is still running. But I had the keys in my hand. Confused the hell out of me.

All the electronics in the Jeep were off, like they should be, except the engine was still running, not even the cooling fan was on. If I put the key in and turn it the electronics come back on and I can drive away like nothing happened.

The only way I have been able to turn off the engine is by disconnecting the battery. I'm going to let it be overnight and hopefully it was just caused by a little water and it'll dry up.

Has anyone experienced this issue before or does anyone know of a possible fix?

BILL
4" Rough Country | TeraFlex Monster Adjustable Track Bar | AEV Snorkel | Delta Grill Lightbar | 4.10s | 35" Toyo Open Country M/Ts | ProComp XTreme 7069 Alloy Wheels | Adam's Front and Rear Driveshafts
JERSEY
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CREW
SJJKUR is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 04-10-2014, 10:15 PM
Rock God
 
Join Date: Dec 2010
Location: Peachland, Okanagan valley, BC
Posts: 1,060
Feedback: 0 reviews

I had a similar problem except it was just the cooling fan. I didn't hit water though. It resolved itself, but yeah I thought my jeep is possessed as well. Freaking PCM! I have chased down the wire harness and relays with no other explanation other than it must be the PCM.

Your problem specifically, I have not heard of before or experienced myself.

JKUR auto | 5:38 | tires 36"x17 wheels 9"x4.5"bs | TF 6"| ASFIR bumpers, skids | SuperWinch EPi9.5 | RCV shafts | SC traildash | Xenon fenders | OBA York

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JeepUpKeep37s is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome