Engine won't shut off....... - JKowners.com : Jeep Wrangler JK Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 31 Old 10-17-2009, 08:22 PM Thread Starter
Newbie
 
Join Date: Oct 2009
Location: Parowan,Utah
Posts: 6
Feedback: 0 reviews
Engine won't shut off.......

I'm new to JKO and hope someone can help.
I have a 2008 JK 3.8, the problem is the engine won't shut off.I turn the key off and it keeps running.I have to disconnct the battery and redo the key on and off several times finally the engine stops.

Any ideas would be great
Thanks
Traneman is offline  
Sponsored Links
Advertisement
 
post #2 of 31 Old 10-17-2009, 08:32 PM
JKO Addict!
 
guinness's Avatar
 
Join Date: Dec 2008
Location: Next Door To Some Shitheads.
Age: 45
Posts: 2,117
Feedback: 1 reviews

No clue on that one. Sounds like an electronics problem that should be handeled by the dealer.

Rest In Peace Guinness. You will never be forgotten. My brother and my best friend
guinness is offline  
post #3 of 31 Old 10-17-2009, 08:36 PM
JKO Addict!
 
SONIC's Avatar
 
Join Date: Feb 2008
Location: Bell Buckle, TN
Posts: 3,730
Feedback: 1 reviews

yeah thats a new one
dealer time

Yes, but there's just something about him. Something around the eyes, I don't know, reminds me of... me. No. I'm sure of it, I hate him.
-Doc Holiday
Why are you highlighting my sig? You Bastard!
SONIC is offline  
Sponsored Links
Advertisement
 
post #4 of 31 Old 10-17-2009, 08:41 PM
Banned
 
Join Date: Aug 2007
Location: Denver
Posts: 3,230
Feedback: 0 reviews
Send a message via Yahoo to WTF_LOL

Quote:
Originally Posted by Traneman View Post
I'm new to JKO and hope someone can help.
I have a 2008 JK 3.8, the problem is the engine won't shut off.I turn the key off and it keeps running.I have to disconnct the battery and redo the key on and off several times finally the engine stops.

Any ideas would be great
Thanks
That is a new one to me as well. Should be a dealer warranty item though

Only thing I can think if is diconnecting the battery for the evening to reset it. People will often have strange computer related issues like this and clearing the ecu usually takes care of the issue. Try leaving it diconnected all night and if it still does it...visit the dealer
WTF_LOL is offline  
post #5 of 31 Old 10-17-2009, 09:20 PM
Alec W
Guest
 
Posts: n/a

Scott, does the 'puter have flash ram?
post #6 of 31 Old 10-17-2009, 09:22 PM
Banned
 
Join Date: Aug 2007
Location: Denver
Posts: 3,230
Feedback: 0 reviews
Send a message via Yahoo to WTF_LOL

flash ram?

I know the physical memory is flash. I would assume the ram is as well but I honestly couldn't answer taht
WTF_LOL is offline  
post #7 of 31 Old 10-17-2009, 09:40 PM
Rock God
 
DiscoBayJoe's Avatar
 
Join Date: Oct 2007
Location: Discovery Bay, CA
Age: 48
Posts: 990
Garage
Feedback: 1 reviews
Send a message via Yahoo to DiscoBayJoe
Christine ][?



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2008 JKUR 3.5" Frankenlift : RK/Artec/Synergy/Reid/Currie/PSC - Spyder'd Out - 35" MTR/K's on Spyderlocks - BinksFab Tailgate
DiscoBayJoe is offline  
post #8 of 31 Old 10-17-2009, 09:49 PM
Rock God
 
jeepersheart's Avatar
 
Join Date: May 2009
Location: South jersey
Age: 34
Posts: 1,121
Feedback: 0 reviews

is this a rubicon we are talkin about? I ask because so may of the strange electrical gremlins with them have been traced back to a faulty electric disco system... at the least its one more thing to rule out.

2008 Detonator 2Dr. 6 Sp.
Olympic double tube sliders I Rugged Ridge front XHD I Smittybilt XRC 8 I Ef's pod I Chopped flares I Rock krawler 2.5" stock mod with Bilstein 5100s I 35" Dick Cepek Crushers


Jersey

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Crew
jeepersheart is offline  
post #9 of 31 Old 10-17-2009, 09:56 PM
JKO Addict!
 
bodyguy's Avatar
 
Join Date: Jul 2008
Location: Shit Creek, Texas
Age: 42
Posts: 4,013
Feedback: 0 reviews

Finally some one else with the same issue. Do you have a Rubicon? if so unplug your sway bar and then stick the key back in and it will turn off.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bodyguy is offline  
post #10 of 31 Old 10-18-2009, 07:53 AM Thread Starter
Newbie
 
Join Date: Oct 2009
Location: Parowan,Utah
Posts: 6
Feedback: 0 reviews

No its not a Rubicon,its the weirdest thing though.
The engine will keep running but nothing else works including the cooling fan.
I was hoping not to have to go to the dealer as the closest one now is 250 miles.
Will try disconneting the battery overnight,will this cure it or might the problem come back.
Maybe it just wants to keep playing. lol

Thanks for the input guys.
Traneman is offline  
post #11 of 31 Old 10-18-2009, 08:10 AM
Rock God
 
Join Date: Sep 2009
Age: 38
Posts: 1,497
Feedback: 0 reviews

does it do this every single time?
savage is offline  
post #12 of 31 Old 10-18-2009, 10:08 AM Thread Starter
Newbie
 
Join Date: Oct 2009
Location: Parowan,Utah
Posts: 6
Feedback: 0 reviews

No. It did it about 2 weeks ago and was fine until last night.
Iam leaving the battery disconnected today and see what happens.

Well done is better then well said !
Traneman is offline  
post #13 of 31 Old 10-18-2009, 10:26 AM
JKO Addict!
 
Ogie's Avatar
 
Join Date: Nov 2008
Location: Huntington Beach, CA
Age: 52
Posts: 2,865
Garage
Feedback: 1 reviews

It could be a few things but my initial guess would be a faulty ignition switch/wiring.

And don't disconnect the battery to try to stop it in the future. Just pull the fuel pump fuse.

Vidi, vici, veni
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2008 Jeep JK Wrangler Rubicon Unlimited
jk-forum, jk forum, jkforum, jeep jk wrangler
Ogie is offline  
post #14 of 31 Old 10-18-2009, 10:51 AM
Rock God
 
Join Date: Sep 2009
Age: 38
Posts: 1,497
Feedback: 0 reviews

Quote:
Originally Posted by Ogie View Post
It could be a few things but my initial guess would be a faulty ignition switch/wiring.

And don't disconnect the battery to try to stop it in the future. Just pull the fuel pump fuse.
I agree with all this.
savage is offline  
post #15 of 31 Old 10-19-2009, 08:20 PM Thread Starter
Newbie
 
Join Date: Oct 2009
Location: Parowan,Utah
Posts: 6
Feedback: 0 reviews

Crap..........did the same thing today.....

Well guess Iam off for a road trip.

Well done is better then well said !
Traneman is offline  
post #16 of 31 Old 10-19-2009, 08:26 PM
Openly Hostile
 
Join Date: Apr 2008
Location: Mission Viejo, CA
Age: 41
Posts: 6,984
Feedback: 4 reviews

Mine did that about a year ago I was lucky tho because I have a manual transmission so I could just put it in 4th and drop the clutch to turn it off.. The dealer had to replace the TIPM

Jason
SDMF is offline  
post #17 of 31 Old 10-20-2009, 02:33 PM
JKowners Vendor
 
Jeep School's Avatar
 
Join Date: May 2009
Location: Sedona AZ
Posts: 1,074
Feedback: 0 reviews

Do you have the remote keyless entry key? We have had Jeeps do weird ignition things that seemed to be key related--they did it when one key was used, but not the spare. The only Jeep (so far) that would not turn OFF, only did it once before we sold it.

I would take it to the dealer. Please do share if you find out what it is!

Nena Barlow

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-- downloadable maps & trailbooks

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jeep School is offline  
post #18 of 31 Old 10-20-2009, 03:12 PM
Granite Guru
 
White Widow's Avatar
 
Join Date: Dec 2008
Location: Denver Colorado
Age: 32
Posts: 207
Feedback: 0 reviews

i disconnected my subwoofer and the engine would not shut off.
is yours disconnected

Thats ill cause they act a different way with me
I feel like no body wanna playa with me
thats real cause they treat me
like a stain on their clothes
they treat me like i got a red nose
White Widow is offline  
post #19 of 31 Old 10-20-2009, 03:46 PM
Alec W
Guest
 
Posts: n/a

Quote:
Originally Posted by White Widow View Post
i disconnected my subwoofer and the engine would not shut off.
is yours disconnected
I took my subwoofer out months ago and have never had this problem.
post #20 of 31 Old 10-20-2009, 04:00 PM
Granite Guru
 
White Widow's Avatar
 
Join Date: Dec 2008
Location: Denver Colorado
Age: 32
Posts: 207
Feedback: 0 reviews

Quote:
Originally Posted by Alec W View Post
I took my subwoofer out months ago and have never had this problem.
ya but at the time i disconnected it from inside the speaker. i reconnected it and problem stopped and i just unplugged it at the plug

Thats ill cause they act a different way with me
I feel like no body wanna playa with me
thats real cause they treat me
like a stain on their clothes
they treat me like i got a red nose
White Widow is offline  
post #21 of 31 Old 10-20-2009, 05:28 PM
Rock God
 
jeepersheart's Avatar
 
Join Date: May 2009
Location: South jersey
Age: 34
Posts: 1,121
Feedback: 0 reviews

gotta love this canbus system!! as if electrical gremlins werent bad enough without everything being tied together

2008 Detonator 2Dr. 6 Sp.
Olympic double tube sliders I Rugged Ridge front XHD I Smittybilt XRC 8 I Ef's pod I Chopped flares I Rock krawler 2.5" stock mod with Bilstein 5100s I 35" Dick Cepek Crushers


Jersey

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Crew
jeepersheart is offline  
post #22 of 31 Old 10-20-2009, 06:06 PM
Alec W
Guest
 
Posts: n/a

Quote:
Originally Posted by White Widow View Post
ya but at the time i disconnected it from inside the speaker. i reconnected it and problem stopped and i just unplugged it at the plug
That's weird! Mines done some weird things so I can see that, but it's weird.
post #23 of 31 Old 10-21-2009, 05:18 AM
JKO Addict!
 
Broncojohn's Avatar
 
Join Date: Jul 2008
Location: Dallas, Texas
Age: 46
Posts: 2,522
Garage
Feedback: 0 reviews

Quote:
Originally Posted by jeepersheart View Post
gotta love this canbus system!! as if electrical gremlins werent bad enough without everything being tied together
Yep, agree. Welcome to the wonderful world of Data Bus systems. They can be great, but it can be something totally unrelated and unused that makes some stupid st!t. If this keeps up se should start a Gremlin Sticky Thread. The E-disco is top of the list.

Obama, The greatest gun salesman since the invention of firearms.
Quote:
Originally Posted by Jscwerve View Post
This is exactly why we need to practice proper gun control.

If he was aiming down the sights correctly and had plenty of practice rounds under his belt, there would only be one side of this story.
Broncojohn is offline  
post #24 of 31 Old 10-21-2009, 06:02 AM Thread Starter
Newbie
 
Join Date: Oct 2009
Location: Parowan,Utah
Posts: 6
Feedback: 0 reviews

No its not keyless entry and subs are connected.
I thank you for all the input,it will be a couple of weeks before I can get it to a dealer but will let you know what they find.

Well done is better then well said !
Traneman is offline  
post #25 of 31 Old 10-21-2009, 09:22 AM
Granite Guru
 
Mule'Con's Avatar
 
Join Date: Apr 2009
Location: Santa Rosa, CA
Posts: 479
Feedback: 0 reviews

My guess, based on the young age, the Jeep wants to be driven more, and not ready to rest. Just like my 8mo mini aussie. JK, let us know what the dealer says.

2008 Red Rock Rubicon Unltd 6spd dual top
Mule'Con is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome