Bad cluster 2010 rubi - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-17-2014, 03:05 PM Thread Starter
Wheeler
 
Join Date: May 2012
Location: Conway, SC
Age: 45
Posts: 45
Feedback: 0 reviews
Bad cluster 2010 rubi

My cluster keeps getting shorted/burned out. They are putting the 3rd one in. Has anyone had this happen to them. When it goes bad the jeep will start, the wipers are permanently on and it wont come out of park. I am still under warranty for 6 months or 10,000 miles but this is the 3rd in a year. Getting to be annoying.
plntman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-17-2014, 03:33 PM
JKO Addict!
 
terrahawk's Avatar
 
Join Date: Feb 2008
Location: Katy, TX
Posts: 4,511
Garage
Feedback: 1 reviews

Your real problem lies elsewhere, why haven't the fixed whats causing it?

Pain heals, chicks dig scars, glory lasts forever.
terrahawk is offline  
post #3 of 4 Old 01-17-2014, 07:53 PM
Granite Guru
 
jsukey's Avatar
 
Join Date: May 2013
Location: Fort Worth, TX
Age: 40
Posts: 166
Garage
Feedback: 0 reviews

I would be really weary about that! There's obviously another reason behind it. I would start talking to the service manager and ask if they are going to warranty their work/new cluster once your warranty runs out.

Current vehicles:
2007 Sahara 2-Door
5.38 gears
Trussed, sleeved, gusseted Dana 44 front w/ factory Rubi locker and RCV shafts
Stock rear Rubi Dana 44 with Auburn Ected locker w/ 35 spline chromoly shafts
6 Speed
2.5 Rock Krawler X Factor System w/ Bilstein 5100 shocks
17X9.5 Spyderlock Beadlocks
37X12.50R17 Nitto Trail Grapplers
F&R AEV Bumpers w/ AEV rear tire carrier
JCR Stage 2 rock rails
Warn Zeon 10-S winch

2010 Jeep SRT8 w/ 440 stroker making 550 whp
jsukey is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 01-17-2014, 09:56 PM
Granite Guru
 
babiehughie's Avatar
 
Join Date: Nov 2009
Location: Northern NM
Age: 54
Posts: 398
Garage
Feedback: 5 reviews

I had the same problem - turned out to be the compass module shorted out taking out the instrument cluster. YMMV. Good luck.

Quote:
Originally Posted by STUPIDFACE View Post
I have 2 legs, but 3 knees....right knee.....left knee.....wee knee....
Jack of all Trades, Master of Some
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
babiehughie is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome