RUBICON "BRAIN FRIED AND DEAD" AT 3K - JKowners.com : Jeep Wrangler JK Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-25-2008, 02:20 PM Thread Starter
 
Join Date: Oct 2008
Posts: 104
Feedback: 0 reviews
RUBICON "BRAIN FRIED AND DEAD" AT 3K

So last night as Iam pulling up to my driveway all my different lights start flashig..OIL LEVEL,CHECK ENGINE,ABS,AND EVERY OTHER light that is on the panel. So at this point the JK dies. I jump out and start walking to my house when I hear the "BEEP" and I notice the factory alarm has just armed itself. So I keep pushing the unlock button ob=n my remote and the alarm wont disable. So I unlock the door w/ my keys which set thealarm off and the only way to stop it was to disconnect the battery cable. So I have it towed to the dealership. Another 6 hours later I get the call that the MAIN BRAIN COMPUTER had fried itself and killed my whole electrical system in the JK. The cause I ask???? UH not really sure sometimes they just do this he says, always if it gets wet it can happen. The latter of the 2 I kinda figured since water and electronics dont mix well. Anyway 2 weeks I will be without my Rubi. I just dont get how a brand new JK that has never even been offroad can have a complete and total meltdown before its first oil change.
BLACKJK08 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-25-2008, 02:31 PM
JKO Addict!
 
Dr.Dirty's Avatar
 
Join Date: Jul 2008
Location: Hesperia Ca
Posts: 8,653
Garage
Feedback: 21 reviews

mine did the same and it was caused buy the electric sway bar shorting out i had the exact same thing happen


www.jeepasylum.com
Dr.Dirty is offline  
post #3 of 3 Old 12-25-2008, 07:15 PM
Rock God
 
mcnaught6's Avatar
 
Join Date: Oct 2007
Location: HellPaso, TX - Fort Bliss
Age: 41
Posts: 1,304
Feedback: 0 reviews

my sway bar motor is fried too. now, if i plug the sway bar motor back in, the jeep won't start, so i just have to leave it unplugged.

plugging it in doesn't cause the alarm to go off or lights to flash, when it is plugged in, it screws with the ABS module and the PCM somehow.
mcnaught6 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome