Knock Sensor - JKowners.com : Jeep Wrangler JK Forum
 
JKowners.com : Jeep Wrangler JK Forum  

Go Back   JKowners.com : Jeep Wrangler JK Forum > JK Tech > Stock JK Tech Dept.

JKOwners.com is the premier Jeep JK Forum on the internet. Registered Users do not see the above ads.
Reply
 
Share Thread Tools Display Modes
Old 01-07-2013, 04:00 AM   #1
hellionss
Granite Guru
 
hellionss's Avatar
 
Join Date: Nov 2009
Member # 6992
Location: Hedgesville, WV
Posts: 153
Feedback: 0 reviews
Knock Sensor

I just replaced my clutch (with stock replacement) and now I get a MIL light. When I do the key trick I get no code, but if I pull the code with my flashpaq I get 0325 Knock Sensor curcuit one. This is on an 07 Rubi. Any guidance would be appreciated.
hellionss is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-07-2013, 08:20 AM   #2
ronjenx
Rock God
 
ronjenx's Avatar
 
Join Date: Aug 2010
Member # 10975
Location: Maine
Posts: 1,136
Feedback: 0 reviews
The knock sensor is located on the right side of engine block, to the rear of right engine mount.


P0325-KNOCK SENSOR 1 CIRCUIT

When Monitored:
This monitor runs above 2000 rpm, under open throttle conditions. The Knock diagnostic does not run at idle or during decelerations. The high voltage test runs all the times the engine is running.

Set Condition:
The PCM detects the Knock Sensor voltage out of limits. Two Trip Fault. Three good trips to turn off the MIL.


Possible Causes

KS SIGNAL CIRCUIT SHORTED TO VOLTAGE

KS SIGNAL CIRCUIT OPEN

KS RETURN CIRCUIT OPEN

KS SIGNAL CIRCUIT SHORTED TO THE (K942) KS RETURN CIRCUIT

KS SIGNAL CIRCUIT SHORTED TO GROUND

KNOCK SENSOR

POWERTRAIN CONTROL MODULE (PCM)
__________________
2008 Unlimited Rubicon Automatic

Last edited by ronjenx; 01-07-2013 at 08:28 AM.
ronjenx is online now   Reply With Quote Quick reply to this message
Old 01-07-2013, 08:27 AM   #3
hellionss
Granite Guru
 
hellionss's Avatar
 
Join Date: Nov 2009
Member # 6992
Location: Hedgesville, WV
Posts: 153
Feedback: 0 reviews
Excellent information. Thank you. I will test and report back. Wish me luck.
hellionss is offline   Reply With Quote Quick reply to this message
Old 01-07-2013, 11:00 AM   #4
hellionss
Granite Guru
 
hellionss's Avatar
 
Join Date: Nov 2009
Member # 6992
Location: Hedgesville, WV
Posts: 153
Feedback: 0 reviews
Does anyone know what kind of voltage readings I should be getting from my knock sensor?
hellionss is offline   Reply With Quote Quick reply to this message
Old 01-08-2013, 08:36 AM   #5
hellionss
Granite Guru
 
hellionss's Avatar
 
Join Date: Nov 2009
Member # 6992
Location: Hedgesville, WV
Posts: 153
Feedback: 0 reviews
I am able to read voltage and ignition retard on the superchips. Foes anyone know what kind of numbers I should be seeing?
hellionss is offline   Reply With Quote Quick reply to this message
Old 01-10-2013, 03:15 AM   #6
hellionss
Granite Guru
 
hellionss's Avatar
 
Join Date: Nov 2009
Member # 6992
Location: Hedgesville, WV
Posts: 153
Feedback: 0 reviews
I checked the voltage at the knock sensor above 2000 RPMS and it seems to decrease drastically. Is this normal? What range should I be looking for? Is this decrease of voltage a sign of a bad knock sensor or something else? I looked the wiring over and can not find any sort of shorts or anything.
hellionss is offline   Reply With Quote Quick reply to this message
Old 01-10-2013, 09:04 AM   #7
ronjenx
Rock God
 
ronjenx's Avatar
 
Join Date: Aug 2010
Member # 10975
Location: Maine
Posts: 1,136
Feedback: 0 reviews
I couldn't find any data for the knock sensor output.
I do know it will have a constant output of sorts due to engine background noise. A knock will make it spike. The spike's duration may be too brief to show on a meter. A scope would be needed to display it.

Have you checked the wire harness for continuity? I think that's about all you can do.
__________________
2008 Unlimited Rubicon Automatic
ronjenx is online now   Reply With Quote Quick reply to this message
Old 01-25-2013, 05:31 AM   #8
hellionss
Granite Guru
 
hellionss's Avatar
 
Join Date: Nov 2009
Member # 6992
Location: Hedgesville, WV
Posts: 153
Feedback: 0 reviews
Ok. I have not checked the harness for continuity but what I have discovered is the light will only trip after two running cycles during which rpms exceed 2k. If I keep the rpms under 2k for three cycles the light will clear itself. I do get a fluctuating voltage reading from the obd port that drops drastically above 2000 rpms. Also, above 2k rpms the jeep falls on it's face momentarily which I assume is the knock sensor retarding the spark but after a couple seconds it resumes normally until it drops below 2k rpms at which point it acts fine until the rpms reach 2k again. Should I put a new sensor in it and go from there or are these symptoms pointing elsewhere?

Last edited by hellionss; 01-25-2013 at 06:09 AM.
hellionss is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 04:47 AM   #9
hellionss
Granite Guru
 
hellionss's Avatar
 
Join Date: Nov 2009
Member # 6992
Location: Hedgesville, WV
Posts: 153
Feedback: 0 reviews
I may have found a problem. One of my ignition wires (spark plug wires) is damaged. What I don't kbow or understand is would this trip the knock sensor code and nothing else? I would ha e thought I would get a misfire code or something. Still not sure this is the solutuon to the knock sensor code but wires are on order and I will report back once they are installed.
hellionss is offline   Reply With Quote Quick reply to this message
Old 01-30-2013, 05:15 AM   #10
hellionss
Granite Guru
 
hellionss's Avatar
 
Join Date: Nov 2009
Member # 6992
Location: Hedgesville, WV
Posts: 153
Feedback: 0 reviews
Well. New plug wires, no change. I'm thinking I either pinched a wire putting the transmission back in or the mnock sensor itself went bad. Not sure which. Plan to drop the transmission again when I get the chance and check the wiring. What I don't understand is I do get voltage thru to the pcm from the sensor so if I did pinch a wire it must be damaged but not completely severed right? Or am I just over thinking it?
hellionss is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.