Airbag light will not go off! Problem? - JKowners.com : Jeep Wrangler JK Forum
 
JKowners.com : Jeep Wrangler JK Forum  

Go Back   JKowners.com : Jeep Wrangler JK Forum > JK Tech > Electrical & Lighting Tech Dept.

JKOwners.com is the premier Jeep JK Forum on the internet. Registered Users do not see the above ads.
Reply
 
Share Thread Tools Display Modes
Old 04-19-2011, 10:23 PM   #1
nootherride
JKO Addict!
 
nootherride's Avatar
 
Join Date: Oct 2010
Member # 11644
Location: CHICO,CA
Age: 30
Posts: 2,135
Feedback: 0 reviews
Airbag light will not go off! Problem?

So about two days ago this light came on (see pic)
It comes and goes with bumps or turning it seems..
My concern aside from driving me crazy is.. My airbag system malfunctioning or god forbid deploying.. Any input would be great! Or at the very least how to just turn the light/chime off!

Attachment 33317
__________________
Black 2008 x ,Dana30 Aussie locker,Teraflex C gusset's 2.5 Pro comp coils,Adj Rancho Rs9000's JKS quick disconnects,Jks Adj trackbar, 35.13.50.15 Toyo MT's on 15x8 MB Razors, K&N intake,Superchips, Magnaflow muffler,Optima Red top, Poison spyder ricochet rock rails,Solid diff covers, front Mopar rock bumper chopped, HD D-rings,Xrc 8000 winch, HOGG cut fenders!Bedlined interior, 130 watt kc slimlites

Last edited by nootherride; 05-13-2011 at 03:54 PM.
nootherride is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-19-2011, 10:25 PM   #2
StubEXrube
Super Moderator
 
StubEXrube's Avatar
 
Join Date: Jun 2008
Member # 1473
Location: Austin Texas
Posts: 13,574
Garage
Feedback: 5 reviews
I think it's your clock spring going bad/ shorting out. Dealership may be the solution.

What's up with the CEL?
__________________
Poly Performance - Dynatrac - Currie - Goodyear - Poison Spyder - Warn - PSC - AEV - Reid Racing - Off-Road Evolution - Flowmaster - Delta - Riddler - Micky Thompson - Daystar - Skid Row - Uniden - Rebel Offroad - Firestik - Warrior Products - Viair - HiLift - ARB - Kicker - Infinity
StubEXrube is offline   Reply With Quote Quick reply to this message
Old 04-19-2011, 11:48 PM   #3
nootherride
JKO Addict!
 
nootherride's Avatar
 
Join Date: Oct 2010
Member # 11644
Location: CHICO,CA
Age: 30
Posts: 2,135
Feedback: 0 reviews
Quote:
Originally Posted by StubEXrube View Post
I think it's your clock spring going bad/ shorting out. Dealership may be the solution.

What's up with the CEL?

ya thats what i been reading....i absolutely hate going to the dealer for anything but safety is a big thing....i guess another issue is there is no dealer up here(closed) i think there might be one 30 miles north but what a pia!
ya sorry for the bad cell pic..
__________________
Black 2008 x ,Dana30 Aussie locker,Teraflex C gusset's 2.5 Pro comp coils,Adj Rancho Rs9000's JKS quick disconnects,Jks Adj trackbar, 35.13.50.15 Toyo MT's on 15x8 MB Razors, K&N intake,Superchips, Magnaflow muffler,Optima Red top, Poison spyder ricochet rock rails,Solid diff covers, front Mopar rock bumper chopped, HD D-rings,Xrc 8000 winch, HOGG cut fenders!Bedlined interior, 130 watt kc slimlites
nootherride is offline   Reply With Quote Quick reply to this message
Old 04-20-2011, 12:11 AM   #4
StubEXrube
Super Moderator
 
StubEXrube's Avatar
 
Join Date: Jun 2008
Member # 1473
Location: Austin Texas
Posts: 13,574
Garage
Feedback: 5 reviews
Quote:
Originally Posted by nootherride View Post
ya sorry for the bad cell pic..
Oh....I meant that your check engine light was on.
__________________
Poly Performance - Dynatrac - Currie - Goodyear - Poison Spyder - Warn - PSC - AEV - Reid Racing - Off-Road Evolution - Flowmaster - Delta - Riddler - Micky Thompson - Daystar - Skid Row - Uniden - Rebel Offroad - Firestik - Warrior Products - Viair - HiLift - ARB - Kicker - Infinity
StubEXrube is offline   Reply With Quote Quick reply to this message
Old 04-20-2011, 12:19 AM   #5
nootherride
JKO Addict!
 
nootherride's Avatar
 
Join Date: Oct 2010
Member # 11644
Location: CHICO,CA
Age: 30
Posts: 2,135
Feedback: 0 reviews
Quote:
Originally Posted by StubEXrube View Post
Oh....I meant that your check engine light was on.
keys on engine wasnt running...it goes off after
__________________
Black 2008 x ,Dana30 Aussie locker,Teraflex C gusset's 2.5 Pro comp coils,Adj Rancho Rs9000's JKS quick disconnects,Jks Adj trackbar, 35.13.50.15 Toyo MT's on 15x8 MB Razors, K&N intake,Superchips, Magnaflow muffler,Optima Red top, Poison spyder ricochet rock rails,Solid diff covers, front Mopar rock bumper chopped, HD D-rings,Xrc 8000 winch, HOGG cut fenders!Bedlined interior, 130 watt kc slimlites
nootherride is offline   Reply With Quote Quick reply to this message
Old 04-20-2011, 03:56 AM   #6
tjkoen01
Granite Guru
 
tjkoen01's Avatar
 
Join Date: Jun 2010
Member # 10065
Location: Louisville, KY
Age: 33
Posts: 161
Feedback: 0 reviews
Quote:
Originally Posted by nootherride View Post
So about two days ago this light came on (see pic)
It comes and goes with bumps or turning it seems..
My concern aside from driving me crazy is.. My airbag system malfunctioning or god forbid deploying.. Any input would be great! Or at the very least how to just turn the light/chime off!

Attachment 33317
the light is on because it has detected a problem and your air bag(s) may not go off in the event of an accident. clockspring could be bad, but it is an expensive part to replace on just a guess. Have to take it to a dealer to diagnose.
__________________
2008 Rubicon
Rugged Ridge XHD Bumper w/Warn XD9000i
285/70r17 Maxxis Buckshot XMT Mudders
Superchips Flashpaq
Flow Daddy Headers
Gibson Dual Exhaust
tjkoen01 is offline   Reply With Quote Quick reply to this message
Old 04-20-2011, 11:28 AM   #7
nootherride
JKO Addict!
 
nootherride's Avatar
 
Join Date: Oct 2010
Member # 11644
Location: CHICO,CA
Age: 30
Posts: 2,135
Feedback: 0 reviews
Quote:
Originally Posted by tjkoen01 View Post
the light is on because it has detected a problem and your air bag(s) may not go off in the event of an accident. clockspring could be bad, but it is an expensive part to replace on just a guess. Have to take it to a dealer to diagnose.
See they would tell u it's bad just to make a couple bucks too..
__________________
Black 2008 x ,Dana30 Aussie locker,Teraflex C gusset's 2.5 Pro comp coils,Adj Rancho Rs9000's JKS quick disconnects,Jks Adj trackbar, 35.13.50.15 Toyo MT's on 15x8 MB Razors, K&N intake,Superchips, Magnaflow muffler,Optima Red top, Poison spyder ricochet rock rails,Solid diff covers, front Mopar rock bumper chopped, HD D-rings,Xrc 8000 winch, HOGG cut fenders!Bedlined interior, 130 watt kc slimlites
nootherride is offline   Reply With Quote Quick reply to this message
Old 04-27-2011, 08:52 AM   #8
jk007
Wheeler
 
Join Date: Dec 2009
Member # 7341
Posts: 73
Feedback: 0 reviews
Mine come on and it was a bad connection under the passenger seat, probably after some stuff was push to hard and broke a wire, have to replace the complete seat harness. Check engine isn't suppose to stay on if that's an airbag problem, the airbag light take care or those info
jk007 is offline   Reply With Quote Quick reply to this message
Old 04-27-2011, 09:06 AM   #9
rdhrd4
Rock God
 
rdhrd4's Avatar
 
Join Date: Oct 2009
Member # 6573
Location: Lakenheath, UK
Age: 25
Posts: 1,708
Feedback: 0 reviews
Quote:
Originally Posted by jk007 View Post
Mine come on and it was a bad connection under the passenger seat, probably after some stuff was push to hard and broke a wire, have to replace the complete seat harness. Check engine isn't suppose to stay on if that's an airbag problem, the airbag light take care or those info
this, check your connections under-seat. also, idk if jeep does this, but with fords, they will blink a certain number of times,

say blink 3 times, pause, blink 7 times... this is a code 37 which can be looked up, does it blink at all when you turn the key on? more than likely it will be a clock spring since you said when you turn the wheel, definately a dealership fix IMHO, although some have DIY'd it...


edit, you can also check the connection that is in the steering wheel, there should be a harness connection on the driver door side of the wheel, you may have to take off a small panel to see it, but check that as well, as this could cause a problem while turning...
__________________
I LIVE, I RIDE, I DESTROY, ANYTHING I GET BEHIND THE WHEEL OF
Quote:
Originally Posted by karnuvore View Post
But you either support your troops or you are shit.

rdhrd4 is offline   Reply With Quote Quick reply to this message
Old 04-27-2011, 03:50 PM   #10
dtcc687
Rock God
 
dtcc687's Avatar
 
Join Date: Aug 2009
Member # 5534
Location: Woodbury Heights, nj
Age: 26
Posts: 1,405
Feedback: 0 reviews
Mine turned off after I cleaned my connectors under the seat. With all the water that's always it my jeep I'm suprised it doesn't happen more often.
__________________
Steel Blue 07 2dr
"Its the A.M bitches, its time for donuts!"
Jersey
.. ..
Crew
dtcc687 is offline   Reply With Quote Quick reply to this message
Old 04-27-2011, 04:01 PM   #11
Muvovr
JKO Addict!
 
Muvovr's Avatar
 
Join Date: Jan 2010
Member # 7570
Location: DWG, Texas
Posts: 3,095
Feedback: 1 reviews
Could Be

Clock Spring
Seat Position Sensor malfunction
Airbag


I have replaced the Airbag $275 and the clockspring about $275.

Still have the light but no chime.......... Mine is a seat position sensor issue I have yet to resolve. BUT I AM WORKING ON IT !!!

__________________
My Parts need Parts.......
Muvovr is offline   Reply With Quote Quick reply to this message
Old 04-27-2011, 05:09 PM   #12
redneckjk
Rock God
 
redneckjk's Avatar
 
Join Date: Sep 2009
Member # 5994
Location: Pontotoc, Ms.
Age: 52
Posts: 865
Feedback: 0 reviews
mine did this 2 years ago. dealer replaced the driver's seat (go figure) under warranty. started again in Moab last week intermittently.

they started by changing the passenger seat belt assembly, problem returned after a couple of days. then they changed the switch that controls that light, problem returned after a couple more days. then i got the new 2010 drivers seat ( in an 08 ) and fixed. until now.
redneckjk is offline   Reply With Quote Quick reply to this message
Old 04-27-2011, 05:51 PM   #13
johnmcd
Rock God
 
johnmcd's Avatar
 
Join Date: Jun 2009
Member # 4881
Location: Raleigh, NC 4 hours from anywhere, atleast!
Age: 36
Posts: 1,189
Feedback: 0 reviews
Mine's been on since I flooded int interior and then ripped out the rugs. Although I kinda think it might be a clock spring issue, there is play in the wheel at the wheel to shaft connection. I have about 3/8" of front to back play at the top of the steering wheel, it knocks when i do it.
__________________
Quote:
Originally Posted by H.I.I.K View Post
Ok We need to organize a "Strippers and Blow Trail Run" It can raise money for college scholarships
Raleigh Meet and Greet,
Check the thread -------------> HERE
johnmcd is offline   Reply With Quote Quick reply to this message
Old 05-03-2011, 11:49 AM   #14
UGET IT
Rock God
 
UGET IT's Avatar
 
Join Date: Jul 2010
Member # 10522
Location: Folsom Ca.
Posts: 754
Garage
Feedback: 1 reviews
Check all of the connections under the seats...............Just installed PRP Recliners and no issues...........
__________________
Method Motorsports


Email: kevin@methodmotorsports.net
UGET IT is offline   Reply With Quote Quick reply to this message
Old 05-03-2011, 11:55 AM   #15
nootherride
JKO Addict!
 
nootherride's Avatar
 
Join Date: Oct 2010
Member # 11644
Location: CHICO,CA
Age: 30
Posts: 2,135
Feedback: 0 reviews
Quote:
Originally Posted by UGET IT View Post
Check all of the connections under the seats...............Just installed PRP Recliners and no issues...........
Good call I'll have all the seats out ect in few weeks to bedline I'll check them all pretty good
__________________
Black 2008 x ,Dana30 Aussie locker,Teraflex C gusset's 2.5 Pro comp coils,Adj Rancho Rs9000's JKS quick disconnects,Jks Adj trackbar, 35.13.50.15 Toyo MT's on 15x8 MB Razors, K&N intake,Superchips, Magnaflow muffler,Optima Red top, Poison spyder ricochet rock rails,Solid diff covers, front Mopar rock bumper chopped, HD D-rings,Xrc 8000 winch, HOGG cut fenders!Bedlined interior, 130 watt kc slimlites
nootherride is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:46 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.