Cruise Control Problem - JKowners.com : Jeep Wrangler JK Forum
 
JKowners.com : Jeep Wrangler JK Forum  

Go Back   JKowners.com : Jeep Wrangler JK Forum > JK Tech > Electrical & Lighting Tech Dept.

JKOwners.com is the premier Jeep JK Forum on the internet. Registered Users do not see the above ads.
Reply
 
Share Thread Tools Display Modes
Old 12-10-2010, 06:15 AM   #1
erikprime
Wheeler
 
Join Date: Apr 2010
Member # 9013
Age: 28
Posts: 56
Feedback: 1 reviews
Cruise Control Problem

2007 X

i hit the button, and nothing happens...wont turn on... aside from checking a fuse, anybody have any advice? has this happensed to anyone else?
erikprime is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-10-2010, 08:31 AM   #2
thisbejonas
Granite Guru
 
thisbejonas's Avatar
 
Join Date: Apr 2010
Member # 9182
Location: Oklahoma City (Choctaw)
Posts: 382
Feedback: 1 reviews
Mine does the same thing. I can turn the cruise on and the "cruise" light comes on in the cluster then hit the set button and it does nothing. Its a real PITA since I do alot of interstate driving.
thisbejonas is offline   Reply With Quote Quick reply to this message
Old 12-10-2010, 09:17 AM   #3
JK-Ford
Granite Guru
 
Join Date: Mar 2009
Member # 3772
Location: Cabot, AR.
Age: 51
Posts: 126
Feedback: 0 reviews
I have seen others on diffrent forums with the same problem. I think that the contacts on the switch are cheep. Pull the switch and use a meter to check?
__________________
"The Green Monster"
2007 2 Door X Jeep Green with Freedom Top
16" Painted Aluminum Mopar Wheels
Grab Bar Mod on front bumper
130w KC Daylighter Driving Beams on grab bar
130w KC Daylighter Long Range Beams
on
Smittybuilt Windshield Brackets
Rock Light Mod
Reverse Light Mod
Mood Light Mod
JK-Ford is offline   Reply With Quote Quick reply to this message
Old 12-10-2010, 10:09 AM   #4
jeepRcreepR
Granite Guru
 
jeepRcreepR's Avatar
 
Join Date: Feb 2010
Member # 7996
Location: Bradenton, Fl
Posts: 437
Feedback: 3 reviews
Are you having sensor problems (ESP, traction control type stuff). When I lifted my jeep my sensors would go crazy with every turn. Had a bad speed sensor which knocked out my whole cruise control.
__________________
07 JKU Rescue Green with 3.5" RK Mid-Arm Flex w/ Bilstein 5100s, 5.13's, Eaton E-Locker, 35" MT Baja ATZ, 17" DC Torque wheels, Monstalined tub, Home-made front bumper with Smittybilt XRC-8 winch, Wild Boar rack w/ IPF 968 lights, K&N Intake, Gibson Exhaust.
Future Mods: 2wd-4wd conversion = completed!
jeepRcreepR is offline   Reply With Quote Quick reply to this message
Old 12-10-2010, 10:39 AM   #5
thisbejonas
Granite Guru
 
thisbejonas's Avatar
 
Join Date: Apr 2010
Member # 9182
Location: Oklahoma City (Choctaw)
Posts: 382
Feedback: 1 reviews
No sensor issues on mine as it is basically stock right now.
thisbejonas is offline   Reply With Quote Quick reply to this message
Old 12-10-2010, 11:13 AM   #6
Fishyguy
Granite Guru
 
Join Date: Oct 2008
Member # 2113
Location: Fort Collins,CO
Age: 33
Posts: 299
Feedback: 3 reviews
I just replaced my clock spring due to this exact same problem.
__________________
08 Detonator Yellow Rubicon-RE Arms-37" Mt/R's with Kevlar-Riddler Diff Cover-LoD stubby with Stinger-LoD stubby tire carrier-Warn M8000 Winch-Rigid D2's-20" Rigid Light Bar-SPOD-PS Rocker Knockers-PS Body Armor-5.13s-hydro assist-RCV shafts-IPF-Corbeau LG1 seats-12" King coilovers-AEV Hood-AEV Snorkel-5.7L VVT Hemi-AEV hemi Install Kit-4.5" AEV Springs-ProRock 44-AlloyUSA Rear shafts-Spyntech Hubs-Raceline Monters-
Fishyguy is offline   Reply With Quote Quick reply to this message
Old 12-10-2010, 11:25 AM   #7
thisbejonas
Granite Guru
 
thisbejonas's Avatar
 
Join Date: Apr 2010
Member # 9182
Location: Oklahoma City (Choctaw)
Posts: 382
Feedback: 1 reviews
Quote:
Originally Posted by Fishyguy View Post
I just replaced my clock spring due to this exact same problem.
Clock spring?
thisbejonas is offline   Reply With Quote Quick reply to this message
Old 12-18-2010, 08:57 AM   #8
mr_natural78
Wheeler
 
Join Date: Jul 2009
Member # 5441
Location: Valparaiso, Indiana
Age: 36
Posts: 81
Feedback: 0 reviews
Quote:
Originally Posted by jeepRcreepR View Post
Are you having sensor problems (ESP, traction control type stuff). When I lifted my jeep my sensors would go crazy with every turn. Had a bad speed sensor which knocked out my whole cruise control.
I'm in that same boat at the moment. I think I have a bad ABS sensor. I'll go get it checked out eventually.
__________________
Doug
Valparaiso, IN
Tattoos By Doug

2007 Steel Blue X Unlimited
Rubi D44 up front with chromo shafts, riddler cover, and CTM u-joints
4" Frankenlift
black steel wheels
35" AT's
Rock Hard bumper and tire carrier
Nate's 4x4 frnt winch bumper
(custom chopped into a stubby)
Rubi rails
Rock Hard skids
KC 8" driving lights
KC 6" driving lights on KC windshield mounts
Tuffy console insert
mr_natural78 is offline   Reply With Quote Quick reply to this message
Old 12-18-2010, 11:32 AM   #9
zjr
JKO Addict!
 
zjr's Avatar
 
Join Date: Jul 2009
Member # 5296
Location: Inside my beard.
Posts: 3,691
Feedback: 1 reviews
My abs sensor wire got cut, and that killed my cc.
__________________
01111001011011110111010100100000011011000110111101 11001101110100001000000111010001101000011001010010 000001100111011000010110110101100101

Quote:
Originally Posted by caligirl View Post
James just came a little early......
Quote:
Originally Posted by njjk08 View Post
...May 2011 bless everyone with pervert wheeling days...
zjr is offline   Reply With Quote Quick reply to this message
Old 11-22-2012, 07:02 PM   #10
spryan81
Newbie
 
Join Date: Apr 2011
Member # 15150
Location: Raleigh, NC
Age: 32
Posts: 7
Feedback: 0 reviews
bringing it waaaaaaaaaaaaaay back from the dead but... Have any of you guys with the above listed problems had any dash lights come on to indicate bad wheel sensor etc? My cruise control stopped working but I've not no codes... Checked with both an OBDII and the ignition method and all of my fuses are fine... I replaced the switch and still nothing... I haven't checked the continuity of the clockspring yet but was hoping someone had another idea for me before I try that...
spryan81 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JKowners.com : Jeep Wrangler JK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:06 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.