Stupid annoying problems... [Archive] - JKowners.com : Jeep Wrangler JK Forum

: Stupid annoying problems...


oz97tj
03-08-2009, 07:58 PM
Ok, some time last week after getting gas, the gascap message appeared in my new JKs dash. The following day, it set off the check engine light. I've checked the gas cap a billion times now (and gotten gas a couple times over the weekend) and it still shows up. Also, on Friday, I reset the check engine light, but the gascap message is still popping up.


Then tonight coming back from a little trip up north, my compass in the dash went out. I stopped for gas, and restarted the engine and it came back on, but it showed S the whole time, no matter what direction I was pointing. If it matters I have the Daystar tray thing on the center stack and the compass module was attached properly. It hasn't given me any issues over the last 2 weeks I've had it on. I also removed anything I had in the tray to make sure nothing was screwing up the module, but it still read all wrong.

I'm going to call the dealer tomorrow, but does anyone have any ideas? Are these common problems?

chromedome
03-08-2009, 08:20 PM
There is a procedure in the owners manual for recalibrating the compass, it includes driving in circles a few times...
As far as the check engine / gas cap, You may have an evap system leak that is setting off the gas cap warning.

WTF_LOL
03-08-2009, 08:24 PM
might try disconnecting the battery for a while. Sometimes the computer seems to get a screwy and needs reset.

Also the gas cap issue normally resets after so many on/off cycles and miles driven

oz97tj
03-08-2009, 09:54 PM
There is a procedure in the owners manual for recalibrating the compass, it includes driving in circles a few times...
As far as the check engine / gas cap, You may have an evap system leak that is setting off the gas cap warning.

I pulled the code that set off the check engine light and it said "loose fuel cap". Ugh. There are codes for evap leaks, but I got the loose fuel cap code.

venom
03-08-2009, 10:40 PM
Did you have your cell in the daystar cubby?
If you put your cell phone in it, a lot of cell phones confuse the hell out of the compass module being that close to it!
I can't put either of my cells up there or my compass wigs out.

oz97tj
03-09-2009, 12:16 PM
Did you have your cell in the daystar cubby?
If you put your cell phone in it, a lot of cell phones confuse the hell out of the compass module being that close to it!
I can't put either of my cells up there or my compass wigs out.

I did have my cell up there. But I've had my cell up there over the past two weeks and haven't had a problem till yesterday. After I removed my cell, it was still screwed up for the 3 hour drive. Today it seemed to be working fine though.

I contacted the dealer about the gas cap issue. They ordered a new one, stating it hasn't been uncommon for the caps to be defective causing the light to go off.

CONVICT
03-09-2009, 12:19 PM
After I removed my cell, it was still screwed up for the 3 hour drive....

I hope it wasnt 3 hours cuz u got lost! :thefinger:

oz97tj
03-09-2009, 12:20 PM
I hope it wasnt 3 hours cuz u got lost! :thefinger:

lol. No, it was due to crappy weather. It's normally a 2 hour drive though.